PDA

View Full Version : power pro 256 problem AGAIN



coonass
04-25-2012, 02:03 AM
Its a shame to have to post on the forum to get a call back. Ive had nothing but problems from the start, first week I had the machine inverter failure. Mailed it back they paid the
Postage. Only problem was it took 6 Weeks to get it back. When I did finally get it back it worked perfectly. I really like the machine but the service turnaround is way to slow imo.
That was in September,now its 4/15/12 problems again. I was finishing up a twin turbo build when my amps dropped to 60 from 140 when welding and when I stopped the display was erratic showing 265 amps and the post flow stayed running. I was a little hot good thing I had a backup welder. Called customer service talked to Ray he informed me I would have Ship it back. Hmmmm sounds like a lemon. Then its gonna cost 155 to Ship it so make sure u keep ur box if u purchase one of these...... Now I called wanting to know if the found out out the problem no answer.. Called back no answer left a message no return call wtf......next day I called back it was the typical no answer maybe their phones are from Everlast also and broken. Just joking.left a message no return call they are fast to sell u one but u c now after my problems this is bad for business. Gimme a break plz fix this green machine. I shoulda bought a miller..........

Rodsmachineshop
04-25-2012, 02:10 AM
best to deal with oleg or alex how old was the machine forgot i dont buy Multi Process Units i use only a unit for each job i have a tig , a mig and plasma all separate units never liked Multi Process Units , I don't have time to waist changing to what job i am doing

coonass
04-25-2012, 02:12 AM
I guess it 8 months old and I really dont know because its not the same one I shipped back the first time.

Rodsmachineshop
04-25-2012, 02:16 AM
forum is best since they all are there checking .

Rodsmachineshop
04-25-2012, 02:17 AM
if i am rite it has a year warranty before you have to pay shipping after a year i know the buyer pays shipping . also sorta high on shipping what you paid i just shipped awhile back to upgrade amachine to abigger on and both ways was only 48.00 dollars but i have a fedex account you can get a fedex or ups account for free saves on shipping

coonass
04-25-2012, 02:21 AM
Nope I had to pay its 30 freaking days only gimme a break I had a harbor freight tig that still runs and no problems hmph......

Rodsmachineshop
04-25-2012, 02:28 AM
yep just read warranty 30 days well i dont mind much since i get good fedex rates

Oleg
04-25-2012, 02:28 AM
Nope I had to pay its 30 freaking days only gimme a break I had a harbor freight tig that still runs and no problems hmph......

Adam , i will make sure your pp256 will go out in 1-2 days
will look at it early morning

Rodsmachineshop
04-25-2012, 02:29 AM
what do you use it for tig or everything . i use seperate machines and have back ups so i know i wont be down at my machine shop and fabrication 4x4 stuff

coonass
04-25-2012, 02:53 AM
what do you use it for tig or everything . i use seperate machines and have back ups so i know i wont be down at my machine shop and fabrication 4x4 stuff


I build twin turbo setups on diesels when I figure out how to post pics I have 7 builds I can post.
And its mostly tig DC and AC on some alum. Parts very seldom I use the plasma but it does cut great when I use it on t4 and t6 flanges 1 inch thick

Rodsmachineshop
04-25-2012, 03:44 AM
it sucks when you loose a machine . and have work

coonass
04-25-2012, 10:33 AM
It sure does I recieved a call from Alex assureing he was gonna get my 256 up anf going and shipped out asap I will let u know the turn around. Btw where and how can I post pics on here.

zoama585
04-25-2012, 10:49 AM
when I figure out how to post pics I have 7 builds I can post.


Use the reply with quote button at the bottom right of every post when you want to reply to another person's post like I did here.
Here is a guide to post pics> 6343 if you need more help just ask.

coonass
04-25-2012, 12:16 PM
m
Use the reply with quote button at the bottom right of every post when you want to reply to another person's post like I did here.
Here is a guide to post pics> 6343 if you need more help just ask.

Thanks man it doesent work with that button for the pics maybe because im on my phone..

inthefrey
04-25-2012, 12:37 PM
You know, it would be really great if Everlast opened an EAST COAST repair facility. **hint-hint**

Also, and, not that I encourage anyone to open and try diagnosing problems with their own machine, but, is there any possibility of getting a set of schematics for these units? (Hope I got the punctuation right...:P) Nothing pulling as much current as these units do through a transistor will last forever.

A set of PP 205 schematics would really do a person good after the warranty expires.

I can repair almost anything with a good schematic.

**Broadcast Engineer - Former Navy AE/AT**

coonass
04-25-2012, 12:48 PM
You know, it would be really great if Everlast opened an EAST COAST repair facility. **hint-hint**

Also, and, not that I encourage anyone to open and try diagnosing problems with their own machine, but, is there any possibility of getting a set of schematics for these units? (Hope I got the punctuation right...:P) Nothing pulling as much current as these units do through a transistor will last forever.

A set of PP 205 schematics would really do a person good after the warranty expires.

I can repair almost anything with a good schematic.

**Broadcast Engineer - Former Navy AE/AT**


very good idea maybe they will broaden out someday florida would be alot closer for me.

coonass
05-04-2012, 04:18 PM
Got my welder back yesterday... Thanks Alex for the fast turnaround I really appreciate it.
Hooked up my plug and ran it tig on AC and DC both welded great I will be testing plasma and stick with some 7018 later today. Again thanks Alex.

coonass
05-05-2012, 01:46 AM
Well I ran it on stick and used the plasma everything seems right does anyone know of a good mild steel rod for a pp256 I used 6010 burn like arc gouge rods and 6011 leave a hard to remove flux. Any suggestions?

Rodsmachineshop
05-05-2012, 01:48 AM
7018 or 6013 is a good purpose rod i use a lot of 7018 at my shop since has a good penetration

coonass
05-05-2012, 02:26 AM
7018 or 6013 is a good purpose rod i use a lot of 7018 at my shop since has a good penetration

I havent tried the 6013 but 7018 weld so smooth I laid the electrode holder down and it laid out the straight est bead uve ever seen I will give those a try thanks....

Rodsmachineshop
05-05-2012, 02:51 AM
7018 is the best to use for welding thicker metal i use the 6013 on rusty dirty metal good videos on stick welding and types of welding rod http://www.weldingtipsandtricks.com/stick-welding.html

DannyB1954
05-06-2012, 05:26 AM
Well I ran it on stick and used the plasma everything seems right does anyone know of a good mild steel rod for a pp256 I used 6010 burn like arc gouge rods and 6011 leave a hard to remove flux. Any suggestions?

7014 works well.

coonass
05-06-2012, 02:59 PM
7014 works well.

Thanks I will pick some up next time I get electrodes.

coonass
05-06-2012, 03:16 PM
651365146515

This came in a while back a cast aluminum handle on an old outboard..